Problemas na instalação do driver da NVIDIA

Esses dias passei alguns “perrengues” para configurar uma GeForce 8600M GT numa máquina com OpenSuse. Mas como sou brasileira e não desisto nunca, consegui resolver e agora vou compartilhar um pouquinho com vocês. 😉

Primeiro tentei configurar manualmente, baixando o driver no site da NVIDIA e executando mas o problema persistia, nada de conseguir definir a resolução que eu queria e os recursos de tela estendida.

Depois recorri ao YAST, adicionei o repositório, instalei os drivers referentes a minha para e… nada, a mesma coisa acontecia.

Então após uma boa pesquisa na internet e leitura dos logs do meu sistema percebi que o problema estava no módulo nouveau, segue uma breve explicação encontrada para solucionar esse impasse:


To prevent the proprietary NVIDIA driver from conflicting with the default nouveau driver, prevent the nouveau module from getting loaded at boot by blacklisting it:

# echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf

This change might need to be undone if you want to use the nouveau driver again, e.g. after upgrading to openSUSE 11.4 when nouveau might have become more mature and usuable (this doesn’t apply for new installations of openSUSE 11.4).

Depois disso foi só correr para o abraço!! Tudo funcionado… pode mandar o próximo!! hehe

Fonte:
http://en.opensuse.org/SDB:NVIDIA_the_hard_way

Anúncios

Configurando video NVIDIA no OpenSuse 11.2/11.3

OpenSuse 11.2:

Normalmente quando tinha que configurar a dupla OpenSuse 11.x + NVIDIA, logo já vinha um passo-a-passo na minha cabeça:

Adicionar o repositório correspondente a versão da minha placa de video (http://pt.opensuse.org/NVIDIA)
Ctrl+Alt+F1
Logar como root

# init 3
# sax2 -r -m 0=nvidia
# nvidia-settings

Só que hoje fui configurar minha GeForce 7025 e me deparei com o seguinte erro:

anjos:/# sax2 -r -m 0=nvidia

If ‘sax2’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf sax2

E descobri, para a minha surpresa, que o sax2 foi removido do OpenSuse 11.3. E aí, o que fazer?

OpenSuse 11.3:

Adicionar o repositório correspondente a versão da minha placa de video (http://pt.opensuse.org/NVIDIA)
Logar como root (konsole)

# nvidia-xconfig

Reiniciar a interface gráfica
Logar como root (konsole)

# nvidia-settings

Simples né! Nada como ler a documentação.

Abraços. 😀